Error running query: Host is blocked after Amazon RDS SSL/TLS certificate update to 2019

I was using a docker image with 7th version of Redash:
redash/redash:7.0.0.b18042

Everything worked fine until we upgraded the Amazon RDS SSL/TLS certificate for the main database that we run queries against.
When the certificate was applied we started getting the following error for all queries:
Error running query: (1129, "Host '172.31.19.243' is blocked because of many connection errors; unblock with 'mysqladmin flush-hosts'")

I see the suggestion in the error message but it is not the case.

I upgraded redash to 8th version:
image: redash/redash:8.0.0.b32245

I can login and see previously created dashboards and queries but if I refresh them still I am getting the same error.

I found this PR regarding the RDS certificate update: https://github.com/getredash/redash/pull/4304
Am I right that the PR was not included in the 8th version docker image?

Please help me what do I need to do to fix it?
Maybe I am missing something?

Thanks everyone who watched the issue.
I am replying to myself.
It is resolved now. Actual problem was in the database. It really rejected requests.
After rebooting the database everything started working. The reboot was not harmful because this is a replica.
Thanks to developers and community for manuals and shared discussions regarding setup, configuration and upgrade of Redash.