Help upgrading from 5.0.2 to 6.0 - Upgrade guide is not useful


#1

Issue Summary

I’ve installed a production environment on EC2 with the AMI provided on the setup guide. However, the AMIs on the site are for version 5.0.2

The Upgrade Guide doesn’t help clarifying how to do the migration on this case.

The main issue for me is this line:

  1. Update /opt/redash/docker-compose.yml Redash image reference to the one you want to upgrade to.

How do I get a new updated image reference?

Technical details:

  • Redash Version: 5.0.2
  • Browser/OS: N/a
  • How did you install Redash: AWS AMI

#2

That’s a very good question! :flushed: We should make it easy to find. Anyway, in your case it’s redash/redash:6.0.0.b8537.


#3

This is something I hit yesterday when upgrading my local docker images as well.

The approach I used was (manually) taking at look at the URL from the setup.sh file:

https://version.redash.io/api/releases?channel=stable

The “docker_image” entry for the first errr… entry is the one to use. :smile:

An alternative approach is to use the docker hub tags page:

https://hub.docker.com/r/redash/redash/tags

That’s probably easier for people than visually parsing json.


#4

Im struggling too with the upgrade from 5.0.2 to 6.0. It’s probably some rookie mistake but im a bit stumped. Im not using a docker and 5.0.2 was working perfectly. After I did the sudo bin/upgrade I get the floowing when I try and login:

Internal Server Error

The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there is an error in the application.

I had this error before, I think, when there was an error in my .env file relating to the database. I haven’t changed the .env file and postgres is still running. Is the db still the same in 6? This is the db line in my .env file.

export REDASH_DATABASE_URL=“postgresql:///redash”

How do i go about locating/fixing the error? Can I just point the current directory link back to the old version to roll it back?


#5

So I tried this upgrade again on my old VM and the same result.

When you first go in after the upgrade it looks fine - except that there are no datasources, dahsboard, users, or queries. You get the spinning circle. Refreshing the page does nothing but when you logout you cant login again…and you get the Internal Server Error message.


#6

I got the same issue, after upgrading from V5 to V6 i was unable to login with the same Internal Server message error.

On redash log i got this message:
“Redis transport requires redis-py versions 3.2.0 or later. You have 2.10.5”

After update the redis-py to 3.2.0 (with pip install redis==3.2.0) i was able to login but now all queries doesnt work anymore.

On screen i got a “'Error running query: an unknown error occurred. Please try again later.” and on logs this message “AttributeError: ‘float’ object has no attribute ‘iteritems’”


#7

I have the same issue. I upgraded from v3 to v4, then v4 to v6. Was unable to login due to the redis-py version error reported by @CH_TN. After running the pip install I was able to login, then started getting the “AttributeError: ‘float’ object has no attribute ‘iteritems’”


#8

its a depenedency issue.
Install redis-py, celery and kombu version from hand, then it works again.
Without beeing an python/django expert, I did the following:
sudo pip install kombu==4.2.0
sudo pip install celery==4.1.1
sudo pip install redis==2.10.6

Also edited the versions in requirements.txt

Then run upgrade again (or restart)

Find more here:


#9

I ran into this issue as well. Manually installing kombu, celery and redis did not help!
Same issue as @CH_TN and @jfryer_runoranj.com.

Upgrade(v4 to v5 to v6) was completed but not able to execute any queries. The celery.log and api_error.log contains this error line which is happening on redis scripts.

“AttributeError: ‘float’ object has no attribute ‘iteritems’”

Does downgrading to v5 help?


#10

I had to restore v5 from my backup. Was not able to switch the “current” symlink back to the v5 install.


#11

Hi @chris2, i execute those pip install commands and now the queries are working again.

I appreciate your help.
Thanks


#12

I ran the pip installs again, restarted the server, cleared redis and it started working. I was missing the redis flush before!

Appreciate the help. Thanks!