Public dashboard with params refresh unexpectedly

Hey,
Following this thread - Refreshing public dashboard (again)

After upgrading to V.8 and utilizing params on an external dashboard (thanks btw!) we see that sometimes, when changing params, it actually runs the query, but sometimes it fetches cached results which are usually too old for our use case (e.g 16 hours ago).

My questions:

  1. How is this caching mechanism working? (I tried query_results but reached a dead end)
  2. Can i change this logic to force a data fetch from the source DB?
  3. Otherwise, i need to run all available params combinations which sounds a bit too much

That doesn’t sound right. The expected behavior:

  1. Changing a parameter value will re-run the queries linked to that parameter once you hit Apply All.
  2. Refreshing the dashboard with the Refresh button will re-run all the queries with their current param values.

The only time you should see old results on the dashboard is on first load since the cached values are always pulled first.

How did you install Redash? What version hash are you running?

Hi,
We’ve upgraded from V7 (non-docker) to V8 - it included a DB migration.
We are running version: 8.0.0+b32245 (a16f551e)

I don’t see any errors in the logs.

Thanks

@susodapop you have any idea how to address this? (see tomtom’s redash specs above)

I’m not certain from the OP that the behavior is out of spec. Can you describe further the issue you see?

Here’s an example- https://i.imgur.com/EwqtTvu.gifv
A hack i found is to add a random() or sysdate functions, then the queries are always refreshed (i assume it avoids the cached results?)