Query Autocomplete

Hi Team,

As per the demo:

http://demo.redash.io/queries/143/source#table

The Redash support auto completion. It auto populate the table names and other keywords, However we are using AWS Ec2 ami instance to run the query and it did not auto populate the tables or the keywords. Please suggest if we need to enable it anywhere?

1 Like

Hi,

I was able to auto populate using CTL + space.
Is it some caching or based on query cache it auto populate? I have to use it all the time to get the table name populated.

The demo instance runs the latest version while the EC2 AMI runs the latest stable version. In the latest version we improved the autocomplete experience compared to the one we had in previous versions. This is the reason you see a difference.

I have V9 and the autocomplete still doesnt work.

Hi @adi.raz :slightly_smiling_face:, two questions: 1 - What data source type are you querying? 2 - Does it show the table names and columns for this data source in the left side of the Query Editor page?

Hi

  1. snowflake
  2. yes

Are you certain that autocomplete is enabled? The lightning bolt glyph under the query editor has a strike-through when autocomplete is disabled.

This is the message that appears : “Live Autocomplete Not Available (Use Ctrl+Space to Trigger)”
and I tried Ctrl+Space and it still doesn’t work.

@ds218 @arikfr ?

Hey @adi.raz,

It’s unavailable when it’s a very large schema (with many tables and columns). Ctrl+Space should give you suggestions when you press it while writing the query (it should give you immediate suggestions).

Any updates ?

As I have the same message “Live Autocomplete Not Available (Use Ctrl+Space to Trigger)"
and I can’t make auto complete for the columns
even after ctrl+space

Thanks for providing new information. If auto-complete doesn’t work on your system then we’ll need more info to help debug.

  1. Does a schema appear for your database in the schema viewer?
  2. What is your browser / OS?
  3. Do you see any errors in your JS console when you try to invoke the autocomplete?

1- In the schema viewer yes

2- I use Safari and chrome
I tried both of them

3- I don’t have errors
but I see the auto complete is displayed the table only
even in the where condition

I’m sorry I don’t understand what this means.

select * from table_name Alias
where Alias.column_name = condition

the auto complete in the where condition instead of displaying the column name
it displays the table name even after using alias for the table

What kind of data source is this?

the source system is Redshift

How many tokens does your schema contain? It seems like this might be a performance issue when the schema is too large :-/