Refreshing public dashboard (again)

I cannot get the logic behind the public dashboard refreshing. I need it to show the data at most 2 minutes behind the actual data.

  • I’ve set all the queries to 1 min refresh;
  • I’ve set the dashboard refresh in the logged-in zone to 1 minute;

The result on the logged-in dashboard:

  • every query is being updated regularly (i.e. “a minute ago” everywhere)

The result on the public dashboard:

  • some queries are updated hours ago, when the original dashboard was created
  • some queries were updated at some point in time when I was playing with refresh intervals (~40 minutes ago)
  • one query is being updated regularly (always shows “a minute ago”)

What dark magic should I use to get public dashboard consistently updated?


Mike

Can you provide some further information about your Redash installation? Which version? Where is it hosted?

Does this dashboard use queries with parameters?

Sure! 6.0.0+b8537 (4780bd9c), self-hosted docker-based installation

Yes, sure. After your question, I’ve found that updating queries are ones without parameters =/

Gotcha. This is a limitation of Redash at the moment: query parameters will not work on public dashboards for security reasons. However a fix for this is coming out shortly!

Looking forward to it! Thanks.

Just following up here to say that safe parameters on public dashboards are now available in Version 8.

Hello,

Just revisiting this topic, I am also looking for the refresh feature on public dashboards. Even setting the query refresh and dashboard refresh to 1 minute the public dashboard is not refreshing accordingly.

I can just get the up to date values if I reload the whole page, which I think is against the purpose of the refresh feature.

Any thoughts on that?

I’m using latest self-hosted Redash 8 version, docker based. Right now using as dev version (as I found some issues on using the image provided). Tried version 9 as well, but due some issues with Oracle long queries, got back to 8.

Thanks

Does the behavior you see match OP’s description above? Do the refreshes work for non-parameterized queries? It sounds like a bug to me.

Happy new year!

Yes, it does. Even with non-parametrized queries I’m getting this error.
To ensure I’m checking on all right places, I went back to the query I’m using and updated the dataset, which reflected fine on my dashboard.
But when setting refresh time to 1 minute and even reloading the public dashboard several times, I get no updated data at all.

And just a side question to confirm: should it work for parametrized queries or not?

Thank you