Specific queries does not running as scheduled

Hey,

Most of my queries run as scheduled,
but some specific queries does not run (are not being updated as scheduled).
While I run them manually, they update.

i tried to change their scheduled hour, delete and create them again,
but it did not work.

i’m using Version: 8.0.0+b32245 (a16f551e).
any idea what should i do?
thanks

Do they use parameters?

hey @susodapop,
these queries does not use any parameters, only the : multi-filter format
( e.g : app as “app_name::multi-filter” ).

anything else i can try to fix it?
Thanks!

@susodapop any update on this?
this issue happens in multiple queries, and it forces me to update them manually on a daily basic,
thanks

@susodapop
hi. I also would like to know update on this issue.
Thanks in advance.

I don’t have any information to go on and I can’t reproduce your issue. What other information do you have about these queries? What kind of data source do they connect to? Are you certain they don’t use parameters?

hey @susodapop,
“these queries does not use any parameters, only the : multi-filter format”,

i see that these queries joins tables with views, do you think it could be the issue?
(using Views in the query)
thanks

Probably not. If that were a problem, why do they execute normally on the Query screen?

that true,
what else can we check?
can i send a log or any of that sort , that will help you understand the issue?
thanks

@susodapop
hey, this issue is still happening , any chance someone will look into it?
thank you

Unless you have more information there’s not much else we can do on our end. We aren’t seeing this behavior.

Which version of Redash are you running?

hey @susodapop,
our version is: 8.0.0+b32245 (a16f551e)

What do your logs show? Failed executions?

I’m curious if you may be seeing this bug?

hey @susodapop,
i’m trying to get the logs, but I don’t see any,
is that the right way do get them?
https://www.screencast.com/t/FilSN9c0Do

thanks

No, you’d check the logs in the container itself as opposed to through the application.

hey @susodapop,
i checked, and found this:

  1. even though the query is scheduled in Redash, it does not execute in my container ( We are using Redshift, i looked into my execution logs in redshift, and i see that the query does not run.)

  2. i checked my container (Redshift) error logs, and the query does not appear in that list
    ( actually there are no error logs records that related to the ‘Redash’ user there)

what else can i check?
thanks

Next I would check whether the query refresh jobs are being added to Redis. Is your scheduler process even running?