Static files not found

I am having trouble with loading some files like jquery.js and icons. I have followed the instructions on Docker Dev Guide and apart from some problems with CRLF/LF linebreaks it all went smoothly. Server is up and running at port 5000 and webpack is running at port 8080. But, some elements on initial setup page will not load and I am getting the errors below in the attached image.

I am pretty new to this whole scene so I might have done something obvious that should not have been done but I have tried everything I knew.

I am using Windows 10. Node and npm is up-to-date.

Hey @Ozencb I think this usually happens when neglecting to run npm run build.

Hello. I did build it before starting it. Output looks like this:

The same happens if you access the webpack server instead? (http://localhost:8080)

8080 works fine, assets load successfully.

Nice :slight_smile:. Then I’m not that sure why npm run build didn’t make assets available (perhaps some issue with the command).

For development purposes you can use localhost:8080. It’s also likely that after it worked in there, it will also work if you come back to localhost:5000 now.