504 Gateway Time-out on Self Hosted installation


I tried installing Redash on a ubuntu 18.04. I used the setup. sh script provided in the git hub. The installation was successful. I ama able to see all the Docker images created and the containers running. When I try to access the rehash application using browser, I get the error " 504 Gateway Time-out" . I tried to open using multiple browsers , but no luck. Please help me resolve this .




How much memory does the server Redash runs on has?


The server is a Ubuntu virtual box with 4GB ram. Is there any minimum hard ware requirements?



hi arikfr,
I even tried increasing the ram. I still get the same error. I did not face any issue while installing the setup.sh. Also the “docker container ls” shows all the running containers.

Please help.



I tried running this on a fresh ubuntu 10.04 virtual box. I am getting the same error. Am I doing something wrong?


I just want to make sure, are you really using Ubuntu 10.04 or this was a typo?


Yes. That was a typo. It’s 18.04. sorry.


Can you share the output of docker-compose logs?