Adding Google Sheet query

Hello, I’m having trouble adding a google sheet query.

I followed the instructions on the video ‘How to see Google Sheets in Redash’ but when I click on ‘Create’ -> ‘New Query’ I get the error:

It seems like we encountered an error. Try refreshing this page or contact your administrator.

I’m using the Docker based installation guide.

Any help is much appreciated.

Technical details:

  • Redash Version: 8.0
  • Browser/OS: Chrome/Windows 10
  • How did you install Redash: Docker, npm

This error isn’t specific to running a Google Sheet query, right? It happens as soon as you try to load the New Query screen? What exact steps did you follow when setting up Redash?

1 Like

Hi there,

I was able to connect to a Microsoft Server source perfectly. I added some queries, dashboard. Everything was fine. Then I added the Google Sheet source, and now, everytime I go to ‘Create’ -> ‘New Query’ I get the error.

Any ideas? Thanks!

Is there any logs table/folder?

I’ve also tried with a MacOS environment and got the same error.

The Docker containers emit logs to their stdout. Can you share what steps you took to setup the data source? Did you upload a key file for the service account?

What I did was:

  1. Added a google service account with role ‘Viewer’.
  2. Created a JSON key and downloaded the json file.
  3. Copied the email designated to the service account
  4. Enabled Google Sheets API
  5. Went to Add New Data Source in Redash, and select Google Sheets
  6. Uploaded the json file from 2.
  7. Went to a google sheet and shared with email from 3.
  8. Create -> New Query -> Error!
1 Like

Those are exactly the right steps. Can you try rebuilding the front-end assets?

npm run build