Athena data source not showing up

I’d like to add an AWS Athena table as a data source, but Athena doesn’t show up at all in my list of sources when I go to add it. I’ve looked around but not found any information, as all the info I’ve found has taken it as assumed that it would be there. I’m on 7.0.0.b17535.
Is there something obvious that I’m missing?

Thanks for any help

Welcome to the forum. A couple questions:

  1. Is this a fresh installation of Redash? Or did you upgrade?
  2. How did you set up Redash (Docker, CentOS, Bitnami etc)

This is an upgrade, most recently from 5 -> 7
I originally set this redash up in 2017. At the time I believe it was via a bootstrap script. Since then I’ve been using the bin/update to update it. It’s running on a Ubuntu server instance right now.

Double check that you installed the Athena Query Runner’s dependencies: pyathena and boto3. Without them, Athena won’t appear on the list of possible sources. You can check this hypothesis in the logs. The relevant line in the source code is here. The log message will look something like this:

query runner enabled but not supported, not registering. Either disable or install missing dependencies

3 Likes

That did the trick. Thanks! For some reason those log entries don’t show up, but installing the missing packages addressed the issue.

1 Like