Autoscale chart

Hi

I have a bar chart where every time I run the query it zooms in and I can’t see the full bars until I select autoscale - is there a way to default to autoscale?
I don’t want to set up max/min for the axis since it uses parameters and the max/min can vary significantly.

Before I select autoscale:

After I click on autoscale (this is what I want it to default to):

That sure seems like a bug. What version of Redash is it?

Version: 8.0.0+b32245 (a16f551e)

I have seen this before when I’ve previously set min/max values for the y axis to specific values, e.g. when using a different metric. Edit the visualization, on the Y Axis settings check that there are no values in either the left or right axis Min Value and Max Value properties. If there are, just delete them and it will default to “Auto”.

Thank you! This worked! Even though there were no values on the max value property, i only had a 0 value for min. After deleting it, it automatically defaulted to auto

1 Like