AWS, Redash, HTTPS

I can’t connect via HTTPS to Redash.

I’m using an AWS Instance, I got it from the Open Source setup page. I’m also using Route 53 to do my domain name.

After following steps provided on the setup page, I then try to set up HTTPS and follow what I found on GitHub.

I can get every other feature working, Databases, Email, HTTP login etc. But once I start to set up the HTTPS, everything breaks and I can’t connect to anything anymore. I believe that I am configuring the nginx files correctly, maybe it has something to do with AWS (But I could get http://redash.mycompany.com to work, just not HTTPS).

The error/breaking step is when I type the command on step 8, or to Generate Certificates. I get the following error:

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: redash.mycompany.com
    Type: connection
    Detail: Fetching
    Connection refused

    To fix these errors, please make sure that your domain name was entered correctly and the DNS A/AAAA record(s) for that domain contain(s) the right IP address. Additionally, please check that your computer has a publicly routable IP address and that no firewalls are preventing the server from communicating with client. If you’re using the webroot plugin, you should also verify that you are serving files from the webroot path you provided.

I’ve tried looking around at what other people said, I tried everything. There isn’t any documentation that I can find about these specifics. Redash, AWS, Route 53, and HTTPS failing. I’ve searched everywhere.

Please help me. I’ve been trying this for days now.

Also, sorry if I left something out, I’m not a pro at documenting or anything.

Nevermind. My co-worker followed the exact same steps, and somehow it worked. I’m more puzzled on why it didn’t work for me. Sorry that I don’t have an exact solution.

I even deleted everything a couple of times trying to make it work. I don’t know what went different.

1 Like