Cannot find ScyllaDB on the datasource type


#1

I just got redash up and running, but when I go to connect, it does’nt appear, its on the list of supported DB’s, but have no idea why its not on mine.


#2

Answered in slack, but cross-posting here for posterity/searchability:

The Cassandra and Scylla DB datasources are enabled by adding redash.query_runner.cass to the REDASH_ADDITIONAL_QUERY_RUNNERS environment variable. You can do this by adding a line like this to your .env file:

export REDASH_ADDITIONAL_QUERY_RUNNERS=redash.query_runner.cass

Or, if you already have another data source enabled, separate them with a comma:

export REDASH_ADDITIONAL_QUERY_RUNNERS=redash.query_runner.python,redash.query_runner.cass