Can't access after launching AWS image

I created an EC2 linux using the AMI provided here: https://redash.io/help/open-source/setup#-Setup and I can log into the linux instance with Putty or WinSCP, but I cannot get the landing page for redash using the DNS as explained in Setup. I updated the security rules to allow inbound SSH, HTTP, HTTPS and am using a key pair I generated on AWS when using Putty and WinSCP. I’m unclear what I’m missing to get the account setup.

What message do you see when you try to connect? A few ideas:

If you see a 500 error
The server is receiving traffic but something went wrong.

If you see a 404 error
The server is receiving traffic but doesn’t know how to find Redash.

If you see a generic “could not connect to host” error
Then it’s probably an issue with DNS and your container isn’t receiving network traffic

Here is what I get when I hit the public DNS. But when I SSH in there are no issues.

Hmmm what happens if you visit it using its domain name instead of the IP directly?

Sometimes it just says connection refused, sometimes I get this:

Progress! This page means the nginx reverse proxy is functioning, but the Redash server itself isn’t actually responding. Are you certain the the container that runs Redash (called server in your docker-compose.yaml) is up and running?

This is a pre-built AMI from redash, so I don’t have the yaml. I looked at the AWS logs but am unsure what I’m looking at, and I’m logged into the linux instance but don’t know where to look there.

I might see an issue–they suggest t2-small, but I launched the default t2-micro. I think I’ll shut it down and try again.

Rebuiding using t2-small has fixed it

1 Like

@eafpres thanks for letting us know how you managed to resolve this. I think what has probably happened is that the t2.micro instance did not have enough resources to start all the containers (services) that Redash relies on hence it did not respond when you tried to browse the home page. The minimum recommended RAM for the Redash AMI is 2GB, which means a t2.small instance or better. In my experience you’ll probably find you need at least a t2.medium once you get any significant usage going.

1 Like