Can't install Python deps with fresh clone of Redash repo

Following the (non-docker) developer setup guide here:

https://redash.io/help/open-source/dev-guide/setup

I get these errors:

$ sudo pip install -r requirements.txt -r requirements_dev.txt
...
ERROR: boto3 1.9.210 has requirement botocore<1.13.0,>=1.12.210, but you'll have botocore 1.12.115 which is incompatible.
Installing collected packages: six, python-dateutil, [...], watchdog
  Found existing installation: six 1.11.0
ERROR: Cannot uninstall 'six'. It is a distutils installed project and thus we cannot accurately determine which files belong to it which would lead to only a partial uninstall.

The “existing installation” error about six is likely due to python3-six being installed by the OS, and isn’t something that can be removed without breaking the system. Might be able to get around this using virtualenv or similar. Will find out.

The boto3 error though seems different. It’s not installed already, so sounds like incompatible requirements being requested. Guessing that won’t be something virtualenv can fix.

Thoughts?

Note - Doing this on a recently installed SuSE OpenLeap 15.x system (laptop), to try and improve my development workflow.

Yep, this happens in a virtualenv too:

...
Collecting botocore==1.12.115 (from -r requirements_dev.txt (line 9))
...
ERROR: boto3 1.9.210 has requirement botocore<1.13.0,>=1.12.210, but you'll have botocore 1.12.115 which is incompatible.

Changing the botocore line in requirements_dev.txt to 1.12.210 (taken from the error message), lets the installation proceed. No idea if it will work properly though. :wink:

Did this end up working after modifying the botocore line in requirements.txt?

Not sure yet. Technically it installed, but I haven’t yet tried running things to find out if it worked properly.

Will be finding out over next few days though. :smile:

Interestingly, the requried botocore line changed to be 1.12.220 now instead of 1.12.210.