Cant see dashboards and queries after importing database backup into v7 Docker

Guys, i am doing a custom install of redash from a V7 self hosted to a V7 Docker instance. Application is working fine however i can’t see all the queries and dashboards in my self hosted redash after PG_Dump import in the docker version. your help is appreciated.

Here is how i deployed my containers:


docker network create redash_default


docker container run -d --read-only --name redis --network redash_default redis:4.0-alpine


docker container run -d --read-only --name postgres --network redash_default --tmpfs=/tmp --tmpfs=/run --tmpfs=/run/postgresql --env-file env -v /mydatavol/:/var/lib/postgresql/data postgres:9.5.21-alpine

docker container run --rm --read-only --name server --network redash_default --tmpfs=/tmp --tmpfs=/run/ -p 5000:5000 -e REDASH_WEB_WORKERS=4 --env-file env redash/redash:7.0.0.b18042 create_db


docker container run -d --read-only --restart always --name server --network redash_default --tmpfs=/tmp --tmpfs=/run/ -p 5000:5000 -e REDASH_WEB_WORKERS=4 --env-file env redash/redash:7.0.0.b18042


docker container run -d --read-only --restart always --name scheduler --network redash_default --tmpfs=/tmp -e QUEUES=celery -e WORKERS_COUNT=1 --env-file env redash/redash:7.0.0.b18042


docker container run -d --read-only --restart always --name scheduled_worker --network redash_default --tmpfs=/tmp -e QUEUES=scheduled_queries,schemas -e WORKERS_COUNT=1 --env-file env redash/redash:7.0.0.b18042


docker container run -d --read-only --restart always --name adhoc_worker --network redash_default --tmpfs=/tmp -e QUEUES=queries -e WORKERS_COUNT=2 --env-file env redash/redash:7.0.0.b18042


docker container run -d --read-only --restart always -p 80:80 -p 443:443 --name nginx --network redash_default --tmpfs=/tmp:rw --tmpfs=/run:rw --tmpfs=/var/run: --mount type=bind,source=/dockervol/redash/nginx/nginx.conf,target=/etc/nginx/nginx.conf --mount type=bind,source=/dockervol/redash/nginx/conf.d/,target=/etc/nginx/conf.d --link server:redash redash/nginx:latest

My ENV file looks like this










  • Next steps

  • Created a DB dumpfile from self hosted v7 redash.gz

  • Created the redash DB in postgres as there was only postgres database in there

  • Then i gunzip -c redash_backup.gz | psql redash

  • ALTER DATABASE redash OWNER TO redash;


My DB currently looks like this

To clarify, some of your queries and dashboard appear while others don’t?

None of my queries or dashboard from the old instance appear. weird as i don’t see any pointer errors on any of the container logs.

I figured this out. redash was still pointing to the postgres db so i changed it to redash db and it worked. All my queries are now appearing however whenever i trying clicking on any of the queries here is what i see:

container logs show this

Nice! Does that error message continue any further? It seems to be cut off…

I am good now. the error stopped after sometime and came up with invalid token error. so i figured it had to do with Redash cookie secret. there was a mismatch in the cookie secret. fixing that solved the issue.

Hi jesse,

I have unrelated issue in my redash application and am hoping to see if you give me some pointers on how to solve it.

  1. New queries with Connection source as Big data isn’t working in my new installation. All old cached queries are working perfectly. since i didn’t see any errors in any of my containers. my thought was it might just be that i need to reconnect to the Big data source signing in with the admin user and that’s where my 2nd problem began

  2. During my initial redash setup i had the Admin setup for username and password before setting up the Google Oauth Login. After setting up the Google Oauth. I can no longer login with Admin username and password. i have tried different scenarios

  • setting my REDASH_PASSWORD_LOGIN_ENABLED=true and rebuilding my containers
  • removing my Google Oauth envs ( client & secret) none of these seem to have worked.

Here is what i see without declaring my google oauth envs

whenever i declare my google oauth envs i am able to logon with google sso.

appreciate your help

Hi, I encounter the same problem. What’s the problem in the cookie secret. What do you do to solve this problem? Thank you very much, looking forward your reply.

In my case, the redash cookie secret environment variable
REDASH_COOKIE_SECRET in my previous installation non docker environment was different to the one in the docker version