Can't use DynamoDB data with DQL


#1

Hi, we failed to connect with DynamoDB using your ap-northeast-1 AMI and the latest version.

Trying something simple like SCAN * FROM test and select * from test, but returns “Error running query: Unrecognized action ‘scan’” and “Error running query: Unrecognized action ‘select’”

System

  • AMI: ap-northeast-1 AMI
  • Version: 0.11.1+b2095
  • Data Source
    – Type: DynamoDB(with DQL)

I can already see my DB tables in query page, so I guess connecting has successfully done. Do you have any ideas?


#2

Unrecognized action is an error that comes from the DQL library. But from looking at their code, SCAN and SELECT are definitely recognizable.

Is your query just SCAN * FROM test or has some other text around it?


#3

My query is only SCAN * FROM test. I tried also SELECT * FROM test_log.


#4

I faced same error also.

First, I tried to use dql in console instead, then execute the same command and there are some error returned.

So, I tried to upgrade the dql.

sudo pip install --upgrade dql

And restart redash, Problem solve.