Cassandra not available in list of datasources

Hi

I launched a Redash instance using EC2 AMI.
Post launching I made the following changes

vi /opt/redash/env
added export REDASH_ADDITIONAL_QUERY_RUNNERS=redash.query_runner.cass in the file.

restarted all the services with
sudo supervisorctl restart all

But still cannot get Cassandra in the list of datasources…

Any idea what I might be missing?

For reference here are some details:

Redash version: Redash 5.0.2+b5486
AMI used : redash-5.0.2-b5486-build2-us-west-2 (ami-0e164aeccb29a1be7)
Cassandra-driver version : cassandra-driver (3.19.0)

Are you using a Docker based setup? If not, you need to make sure you have the Python dependencies for Cassandra installed.

Yes , I think the AMI comes by default with docker based setup only. My Redash services are running as docker only.

Cool, then the issue is:

  1. You don’t need to prefix with env var setting with export – it should be just REDASH_ADDITIONAL_QUERY_RUNNERS=redash.query_runner.cass.
  2. You need to restart using docker-compose's commands. In this I would use docker-compose up -d.
1 Like

Can you share the location of docker-compose.yaml ? I will have to run the docker-compose up -d command in the same directory as the file.

or will the docker restart work?

This is how my /opt/redash/env file looks.

PYTHONUNBUFFERED=0 REDASH_LOG_LEVEL=INFO
REDASH_REDIS_URL=redis://redis:6379/0
POSTGRES_PASSWORD=rhjrjTk84fezMJHrgiat4gPAx7YvGe2O
REDASH_COOKIE_SECRET=Nfb02o78BFwnXQHQXSuG6OIoG0wR64iV
REDASH_DATABASE_URL=postgresql://postgres:rhjrjTk84fezMJHrgiat4gPAx7YvGe2O@postgres/postgres
REDASH_ADDITIONAL_QUERY_RUNNERS=redash.query_runner.cass

It should be located in /opt/redash as well.

1 Like