"Certificate verify failed" trying to access Google Sheet on Redash 7. It's working perfectly on Redash 8

Hi,

I’m trying to read data from a Google Spreadsheet on my production Redash 7 and I’m getting the error message below.

Error running query: HTTPSConnectionPool(host=‘spreadsheets.google.com’, port=443): Max retries exceeded with url: /feeds/spreadsheets/private/full (Caused by SSLError(SSLError(“bad handshake: Error([(‘SSL routines’, ‘tls_process_server_certificate’, ‘certificate verify failed’)],)”,),))

I’ve tested the same configuration (data source and queries) on my Redash 8 local docker installation and it worked beautifully. Any thoughts or ideas?

Thanks in advance,

Arnaldo

I’m not sure immediately. But just to confirm: are the data sources setup the same way with the same JSON key file?

Have you tried creating a separate Google Service Account?

Hi @susodapop, thanks for your fast reply! I’ve checked the JSON key file more than once, so I guess there’s no problem here. For Google Sheets, I’ve created a separate Google account (Gmail/Google Drive) and created a Google API Service Account according to the instructions on this page.

Do you think there’s any possibility that the certificate repositories on Redash’s docker containers are out of date?

Bye!

Arnaldo