[closed] How to disable redash SQL parser?


#1

I’m using PrestoDB as Redash data source.
I want Redash pass my Query to PrestoDB via SQLAlchemy literally without checking grammar or function existence, since PrestoDB or other DBAPIs will do this according to their own standard, especially for custom functions.

Is there some way to disable redash SQL parser?

Thank you in advance

=== UPDATE ===
Oh, It seems I make a mistake. Redash DO pass original SQL to PrestoDB.

select date_sub(now() - interval ‘1’ day)
Error running query: line 1:161: Function date_sub not registered


ShenLei


#2

Just to confirm what you already figured: Redash passes the query as is. The error you receive comes directly from Presto.


#3

Indeed. Thank you for your reply.