Data Source DNS Failure

Issue Summary

Everything worked fine for months but suddenly I get the following error message: “could not translate host name “” to address: Temporary failure in name resolution” when running a query or testing the data source.

It works fine when I input the resolved IP. Running nslookup on the instance itself also result in the correct IP.

Technical details:

  • Redash Version: 10.1.0
  • Browser/OS:
  • How did you install Redash: Digital Ocean Marketplace and incremental upgrade.

Strange that the DNS lookup would fail for an instance spun-up from DO’s marketplace :thinking:

Have you tried restarting the VM?

1 Like

Yes i tried a reboot.

After trying a lot of things and eventually starting from a fresh install, I found what caused the DNS resolver to stop working.

I did the same as before:

  • spin up a new instance from DO’s Marketplace
  • upgrading from v8 → v10 → v10.1
  • migrating with redash-toolbelt
  • setting up ssl

everything worked fine. The DNS worked normally.
But after trying to set up the Email client with this guide: the same problem started to occur right away.

Trying to remove the env-vars did not fix it. I’m not sure why this happens. Maybe the setup doesn’t work with v10.1.0 .

Problem details:

  • DNS works on the instance
  • any docker container, even unrelated to redash, is not able to resolve DNS addresses

I hope someone can help me. So I don’t have to set it up again.


1 Like

Hi again.

After some further investigation, I found the real cause. DO auto-assigned a firewall to the droplets and this apparently somehow blocked the DNS resolver from working.

Disabling it fixes the problem.

1 Like

Thank you for sharing your findings. From what you had described it seems pretty unlikely that there was an issue with Redash. But without eyes on the actual environment it’s hard for the community to guess what the specific error could be: there’s just too many options.

Glad you sorted it out!