Do not load the map


#1

I need your help.
I do not load the map, I use an instance of redash of bitnami.
Any suggestions …


#2

Did you set height for the map? (it’s one of the visualization option)


#3

Yes.


#4

Maybe try changing the zoom?


#5

I guess is a problem with the library or API.
it’s possible?
Sorry the translation, I use google translate.


#6

@matbott, maybe the data type returned in the query results?
I don’t use the map viz too much, but I think that the lat/lon columns must be float


#7

the values of longitude and latitude it out of a string. maybe that is the problem…

query sql
SELECT first_name, SUBSTRING(full_address, 1, 9) as lat, SUBSTRING_index(full_address,’,’,1) as longitud
from contacts, addresses
Where contacts.id = addresses.id


#8

the values of longitude and latitude it out of a string. maybe that is the problem…

Very likely. Try casting to float.


#9

They were right, the problem was the variable type, does not take string. change the query and pass the data to decimal.
Thank you.


#10

there any way using “:: filter” that shows by default all results of the table?


#11

Continuing the thread of conversation … I have a problem with the map, I set it to use the colors according to a query parameter and running, but if I edit the colors do not change.
Try also modify colors directly in the database accessing http://host-server/admin but not making changes.
That may be what that is not working properly ???