Docker-compose installation problem psycopg2.ProgrammingError 'query'


#1

Hi,
I just pulled the newest version two hours ago that fixed the nginx issue discussed in a related post. I am now running into the following error message when I run docker-compose up
ProgrammingError: (psycopg2.ProgrammingError) relation “queries” does not exist

the terminal output is the following:

worker_1 | ProgrammingError: (psycopg2.ProgrammingError) relation “queries” does not exist
worker_1 | LINE 2: FROM queries JOIN query_results ON query_results.id = querie…
worker_1 | ^
worker_1 | [SQL: ‘SELECT queries.query AS queries_query, queries.updated_at AS queries_updated_at, queries.created_at AS queries_created_at, queries.id AS queries_id, queries.version AS queries_version, queries.org_id AS queries_org_id, queries.data_source_id AS queries_data_source_id, queries.latest_query_data_id AS queries_latest_query_data_id, queries.name AS queries_name, queries.description AS queries_description, queries.query_hash AS queries_query_hash, queries.api_key AS queries_api_key, queries.user_id AS queries_user_id, queries.last_modified_by_id AS queries_last_modified_by_id, queries.is_archived AS queries_is_archived, queries.is_draft AS queries_is_draft, queries.schedule AS queries_schedule, queries.options AS queries_options \nFROM queries JOIN query_results ON query_results.id = queries.latest_query_data_id JOIN data_sources ON data_sources.id = query_results.data_source_id \nWHERE queries.schedule IS NOT NULL’]

Thank you all for your advice.


#2

Did you create the database tables?


#3

I hope I can answer your question the right way,
I ran the command
docker-compose -f docker-compose.production.yml run --rm server create_db

with the following output
Starting redash_postgres_1
Starting redash_redis_1
[2017-02-09 17:30:42,186][PID:7][INFO][alembic.runtime.migration] Context impl PostgresqlImpl.
[2017-02-09 17:30:42,187][PID:7][INFO][alembic.runtime.migration] Will assume transactional DDL.


#4

Did you run it after pulling the new Dockerfile?


#5

:slight_smile: thank you a lot. I made a silly mistake of running
docker-compose -f docker-compose.production.yml run --rm server create_db
but then
docker-compose -f docker-compose.yml which of course did not match

when I ran
docker-compose -f docker-compose.production.yml this error message did not come up again.

thank you for the immediate support


#6

Glad I could help :slight_smile: