Email configuration on AWS returns [Errno 99] Cannot assign requested address

#1

I have set up redash in a private subnet with a load balancer pointing toward my redash instances. The last step I need to do is to set up the email configuration. I originally tested this using the redash AMI from bitnami and everything worked, however, I need to do a custom install and deploy from docker since there are several custom steps that need to occur in the setup.

I am using these configs for the email:

export REDASH_HOST=“http://(internal ip address)”
export REDASH_MAIL_SERVER=“email-smtp.us-east-1.amazonaws.com
export REDASH_MAIL_PORT=“587”
export REDASH_MAIL_USE_TLS=“true”
export REDASH_MAIL_USE_SSL=“false”
export REDASH_MAIL_USERNAME="(SES username)"
export REDASH_MAIL_PASSWORD="(SES password)"
export REDASH_MAIL_DEFAULT_SENDER="(send from email)"

When I run the test email or when I do a full restart of docker I get the following:

socket.error: [Errno 99] Cannot assign requested address

It is very odd since the exact same configs work from the AMI. I’m assuming somehow the host I’ve provided is wrong but I’ve tried every combination of localhost, 127.0.0.1, the private IPs and even created this in a public subnet and tried with public IPs and it did not work. Any help would be appreciated.

0 Likes