Error login redash

I can not login redash. Please help me fix this issue!

docker-compose ps
i see that all is up but it still notice error when i login redash via port 5000

It looks like Redash’s database tables have not been created yet.

To fix, run

$ docker-compose run --rm server create_db

Hi Jesse,
i tried this command but when i login via IP and port 5000, it shows as picture below.

Please help this case!

It very much appears that you have not built the front-end assets. You can do this by running yarn build.

do i have problem with version node. Currently, i install node js version 16.14.0?

I tried command yarn build but some issue still is occured on my system. Please help!
[root@localhost redash]# yarn build
Internal Error: redash-client@workspace:.: This package doesn’t seem to be present in your lockfile; run “yarn install” to update the lockfile
at tF.getCandidates (/root/.yarn/releases/yarn-3.2.0.cjs:437:4480)
at wd.getCandidates (/root/.yarn/releases/yarn-3.2.0.cjs:395:1281)
at /root/.yarn/releases/yarn-3.2.0.cjs:441:7765
at Pg (/root/.yarn/releases/yarn-3.2.0.cjs:394:11098)
at le (/root/.yarn/releases/yarn-3.2.0.cjs:441:7745)

You’ll need the specified version of node, which is version 14