Error trying to install on Ubuntu 16.04 Container


#1

Hi,

Any pointers for installing directly into a container with Ubuntu 16.04? I need to prepare an image for quick release into production whenever needed, hence trying the fresh install.

These are the steps I’m taking:

docker container run -u root -p 5000:5000 -it --name ubuntu-redash-all ubuntu:16.04 bash

I copy the file inside the container:

docker cp ubuntu-script.sh ubuntu-redash-all:/home

Finally, inside the container’s bash command line, I run the script:

bash ubuntu-script.sh

After a few long steps I get: line 58: sudo: command not found and Not creating home directory/home/redash’.`

Thank you in advance for your very appreciated comments.


#2

Why aren’t you using the official images (redash/redash)?

Creating a single Docker image with all the peripheral software (pg, Redis, etc) on it is very unidiomatic and will lead you into a world of pain.


#3

I did try using the docker-compose.production.yml but it failed.

running “docker-compose -f docker-compose.production.yml run --rm server create_db” results in an error asking if my postgressql server was indeed online. Now I ran it again I was able to access localhost:80 to initialize the configuration.

However, the command docker-machine ls yields an empty list. Why is that and what is the usefulness of this information if I can access it through localhost? Is this useful only when I’m on a server and need to access it from outside the private network?

Thank you and sorry for the basic questions. I’m starting both with docker and Redash at the same time.