Errors from 'npm run build'

Just trying to bring my dev environment up to date… I’m not using Docker so was manually running “npm install; npm run build” to build the client side (sorry, not a Javascript dev - so I’m pretty clueless about npm, but in the past it’s just completed successfully).

When I run it for the master branch from git I’m getting a bunch of errors, however, so the front end isn’t building. Many are just about the order of imports, but also things like:

/home/redash/redash/client/app/components/ParameterValueInput.jsx
57:7 error Do not use setState in componentDidUpdate react/no-did-update-set-state

Have I done something wrong so that the wrong versions of deps are being pulled in?

Dug a bit more into this npm stuff… Looks like this is just the state things are in at the moment and these are all eslint errors. If I run webpack without the “production” mode then it doesn’t run eslint and I can get on with what I want to do!

It’s not. eslint is not supposed to raise any errors on the codebase at the moment (you can see the same in CI).

Maybe it’s an issue of outdated Node.js or npm version on your system?

I thought that at first when I saw all the errors on a old CentOs machine, so tried on Ubuntu 18.04.3 (just with system installed Node/NPM) and got the same problem.

Do we know what versions of npm / node are required?

FWIW it builds fine once I do (from the redash source dir):

npm install n
N_PREFIX=~/node-for-redash/ node_modules/.bin/n lts
export PATH=~/node-for-redash/bin:$PATH
npm install 
npn run build