Errors on setting up a local instance -- npm run build

Thank you advance!

OS: Cent OS 7

Followed steps on page https://redash.io/help/open-source/dev-guide/docker

Got errors at npm run build

Errors:

npm ERR! Linux 3.10.0-957.21.3.el7.x86_64
npm ERR! argv “/usr/local/n/versions/node/12.13.0/bin/node” “/bin/npm” “run” “build”
npm ERR! node v12.13.0
npm ERR! npm v3.10.10
npm ERR! code ELIFECYCLE
npm ERR! redash-client@9.0.0-alpha build: npm run clean && NODE_ENV=production node --max-old-space-size=4096 node_modules/.bin/webpack
npm ERR! Exit status 2
npm ERR!
npm ERR! Failed at the redash-client@9.0.0-alpha build script ‘npm run clean && NODE_ENV=production node --max-old-space-size=4096 node_modules/.bin/webpack’.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the redash-client package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! npm run clean && NODE_ENV=production node --max-old-space-size=4096 node_modules/.bin/webpack
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs redash-client
npm ERR! Or if that isn’t available, you can get their info via:
npm ERR! npm owner ls redash-client
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR! /home/nan1.wu/redash/npm-debug.log

Screenshot for :5000 page as below

  • Nan

I had a fresh CentOS 7 instance and followed @justinclift’s https://github.com/justinclift/redash/blob/redash-centos7/setup/setup.sh and it worked… From your errors, it seems like you may not have the latest/right version of node.js installed?

Thanks for sharing, I actually updated node.js then tried again, same thing. I will execute .sh file and see what will happen, thanks.