Export issue with ver 8

Hello,

We have a dockerized ver 8 of Redash instance.

After doing some research and looking around, we realized that it is a problem with the export feature in the new Redash.

We have set the date format in Redash as DD-MM-YY (in both new and old). When you see the query results in Redash you will get the date field in this format. But when the data is exported as CSV format in the old Redash, it was getting exported as YYYY-MM-DD. But in the new Redash, it is exported as DD-MM-YY.

When we export the results into the CSV file and into Google sheet, the default date format is taken i.e. MM-DD-YY. So, wherever there were discrepancies (e.g. 17/07/19), those were treated as a text field. In the older version, we did not face this issue as the year in the date was mentioned as YYYY format by the export feature.

In order to fix this issue with the Google sheets, we tried to change the output from DD-MM-YY to YYYY-MM-DD, and then rerun the query and later export it to Google Sheets. This time it worked. Both the output of the query and exported date are shown in YYYY-MM-DD format.

Is there any other better solution, as we have a few hundreds of queries that are being exported to Google Sheets

Thanks in Advance.
Krishna

How are you exporting to Google Sheets?