Fail to start redash on pre-built docker image

install redash by docker-compose is to slow for me so I tried to start redash on pre-built docker image. According to this gist, I do as follow:

docker network create redash
docker run -d --name postgres -v /usr/var/run/redash/postgres:/var/lib/postgresql/data --restart unless-stopped --net redash postgres:9.3
docker run -d --name redis --restart unless-stopped --net redash redis:2.8
docker run -it --rm -p 5000:5000 --net redash --env-file redash-config redash/redash /app/manage.py database create_tables
docker run -it --rm -p 5000:5000 --net redash --env-file redash-config redash/redash /app/manage.py users create --admin --password admin "Admin" "admin"

docker inspect postgres

docker run --rm --net redash -it postgres:9.3 psql -h 172.20.0.2 -p 5432 -U postgres -c "CREATE ROLE redash_reader WITH PASSWORD 'redash_reader' NOCREATEROLE NOCREATEDB NOSUPERUSER LOGIN"

docker run --rm --net redash -it postgres:9.3 psql -h 172.20.0.2 -p 5432 -U postgres -c "grant select(id,name,type) ON data_sources to redash_reader;"

docker run --rm --net redash -it postgres:9.3 psql -h 172.20.0.2 -p 5432 -U postgres -c "grant select(id,name) ON users to redash_reader;"

docker run --rm --net redash -it  postgres:9.3 psql -h 172.20.0.2 -p 5432 -U postgres -c "grant select on events, queries, dashboards, widgets,visualizations, query_results to redash_reader;"

docker run --net redash -it --rm -p 5000:5000 --env-file redash-config redash/redash /app/manage.py ds new "re:dash metadata" --type "pg" --options "{\"user\": \"redash_reader\", \"password\": \"redash_reader\", \"host\": \"postgres\", \"dbname\": \"postgres\"}"

docker run -d --name redash --restart unless-stopped -p 5000:5000 --net redash --env-file redash-config redash/redash
docker run -d --restart always -e QUEUES=celery -e WORKERS_COUNT=1 --name scheduler --net redash --env-file redash-config redash/redash
docker run -d --restart always -e QUEUES=scheduled_queries,schemas -e WORKERS_COUNT=1 --name scheduled_worker --net redash --env-file redash-config redash/redash
docker run -d --restart always -e QUEUES=queries -e WORKERS_COUNT=2 --name adhoc_worker --net redash --env-file redash-config redash/redash

 docker run -d --name redash-nginx -v /server/data/nginx-conf-dir/nginx.conf:/etc/nginx/conf.d/nginx.conf --link server:redash --restart unless-stopped --net redash  -p 80:80 -p 443:443 redash/nginx:latest

I can start the web ui, but I cannot do query. I check the page “system status”, the Celery status fail to load. Using “docker container ls”, I realize that the redash/nginx container didn’t start. Any idea what I do wrong?

As for default.conf
I just change the server_name redash.example.com to server_name 10.238.12.203
and for redash-config I just change REDASH_HOST to 10.238.12.203

That .conf file isn’t something we made. Have you tried following the instructions in our documentation?

From the looks of it you didn’t start your workers.

I follow this gist rather than the redash document because install redash by Docker Compose configuration is too slow for me. The install process will break when building the image and downloading the package during ‘pip install…’ or else. Is there a way of install redash by pre-build image?

No. Why is docker-compose so slow for you? What kind of hardware are you using?