Good-first-issues

Hi all,
I would like to contribute to redash. To get started I looked for “good-first-issues” label, but found none. Could anyone guide me here? I would like to start on small issues as a first step.

1 Like

Welcome and thank you! Are you looking for backend stuff (Python) or frontend?

2 Likes

I can work on both Python and React JS. So anything is fine.

1 Like

Hi, so is there any good first issues to start with ? I’m curious :slightly_smiling_face:

Thanks for following up!

I picked out a few relatively easy ones:

We should go through and cull old issues on the repository to make this easier in the future :slight_smile:

3 Likes

Thank you @jesse / @arikfr

Regarding local set-up

Just now successfully completed Redash set-up locally using “Docker Based Developer Installation” guide. It worked like a charm :purple_heart: Brilliant effort by Redash team :clap:

Fyi, while following the set-up document I noticed 2 things. Would like to bring it to your notice.

  1. Step "Uncomment the line containing REDASH_COOKIE_SECRET" mentioned in the doc is no longer applicable I guess, as that line do not exist in docker-compose.yml file
  2. Ran in to 1 issue i.e. "Couldn't find .env file". Unblocked myself by searching in discussion forum and created a .env file with variables REDASH_COOKIE_SECRET & REDASH_SECRET_KEY as suggested. It worked.

Regarding the issue

  1. Please stop supporting dql - I see dql is being used in “dynamodb_sql.py” file. Is the requirement is to remove the dependency completely or asking to upgrade the version of dql ? Could you please elaborate it and provide more details on the request ? Sorry I’m really new to Redash system.

It would be nice to add good first issue like this every month, so someone from community can work on any of these issues.

2 Likes

Strong agree. Lots of good stuff coming for this now that the hosted workload is diminished :slight_smile:

After being on-call for three years straight I’m headed to a silent retreat to decompress. I will regroup Monday.

3 Likes

Hi @jesse/@arikfr I looked in to the below issue and made a fix. Could you assign the issue and provide permissions to raise a PR ?
Data Source Setup: test connection button is disabled after Save · Issue #5455 · getredash/redash · GitHub.

Below screenshot shows enabling of “Test connection” button after Save

Hi @Jyothi , I responded to your private message but also responding here. You don’t need special permissions to open a PR. You can fork getredash/redash, make your changes on a branch of this fork, and then open a PR from your fork/branch to getredash/redash.

I assigned the issue to you. Once you open the PR I’ll review :slight_smile:

1 Like

Hello @jesse

Thank you. I’m happy to put up my first pull request to an open source project :star_struck: Please review it when you are available.

2 Likes

Hi @jesse, got a chance to review this PR #5666

@Jyothi here’s another ping to @jesse to review your PR :slight_smile:

Also, here’s a silly bug for your consideration that may or may not be a good-first-issue:

1 Like