How to add Cassandra Data Source


#1

It does not show up in the list of data-sources. What should I do to use cassandra as a data source?


#2

I have the same question. I have just installed Redash using the bootstrap.sh method on Ubuntu 16.04.


#3

If you installed a recent enough version of Redash, then it means you already have the dependencies installed and then you just need to add Cassandra to the list of enabled data sources. You can do so by settings REDASH_ADDITIONAL_QUERY_RUNNERS to redash.query_runner.cass.

If you used the AMI we provide or the bootstrap script, you just need to add to /opt/redash/.env the line export REDASH_ADDITIONAL_QUERY_RUNNERS=redash.query_runner.cass. Then you need to restart (supervisorctl restart all).

If Cassandra still doesn’t show, make sure you installed cassandra-driver PyPi package (version 3.1.1).


#4

Thanks @arikfr, I’m using version 1.0.3 installed by the bootstrap.sh script.

I’ve reinstalled the driver using pip install cassandra-driver==3.1.1 --force-reinstall --upgrade, and export REDASH_ADDITIONAL_QUERY_RUNNERS=redash.query_runner.cass to the .env file and restarted everything and we now seem to be in business.

Thanks for your reply.


#5

I’m trying redash connection with cassandra using docker. I have exported REDASH_ADDITIONAL_QUERY_RUNNERS var now cassandra appears in the combo box of sources but when I try the conection I have the error: NoHostAvailable: ('Unable to connect to any servers', {u'192.168.0.4': TypeError('ref() does not take keyword arguments',)})

Also, I have cassandra-driver 3.1.1

cassandra-driver (3.1.1)```

Any hint?

#6

I had the same Unable to connect to any servers problem after installing Redash 2.0.0.b2990 in AWS EC2 using the ami-2d3c0a56 pre-baked AMI.

I’ve solved it by forcing the cassandra-driver reinstall to the newest version I found, then restarting Redash services, all as root:

$ pip install cassandra-driver==3.12 --force-reinstall --upgrade
$ supervisorctl restart all

And I used @leinad_87 tip above to check the installed version: pip list | grep cassan

Using a Cassandra server with these versions: cqlsh 5.0.1 | Cassandra 3.6 | CQL spec 3.4.2