How to connect redash to impala?


#1

I tried to run impala_ds.py script but getting following error. Please suggest me to configure impala.

root@vagrant-ubuntu-trusty-64:/home/vagrant/redash-master/redash/query_runner# ./impala_ds.py
Traceback (most recent call last):
File “./impala_ds.py”, line 6, in
from redash.query_runner import *
ImportError: No module named redash.query_runner


#2

You’re not supposed to run this file directly. What are you trying to do?


#3

I am getting following error when run the fabfile.py

127.0.0.1] out: [2016-07-04 10:31:44,283][PID:9764][WARNING][redash.query_runner] Microsoft SQL Server query runner enabled but not supported, not registering. Either disable or install missing dependencies.
[127.0.0.1] out: Traceback (most recent call last):
[127.0.0.1] out: File “migrations/0003_update_data_source_config.py”, line 90, in
[127.0.0.1] out: for data_source in DataSource.select(DataSource.id, DataSource.name, DataSource.type, DataSource.options):
[127.0.0.1] out: File “/usr/local/lib/python2.7/dist-packages/peewee.py”, line 1898, in next
[127.0.0.1] out: obj = self.iterate()
[127.0.0.1] out: File “/usr/local/lib/python2.7/dist-packages/peewee.py”, line 1884, in iterate
[127.0.0.1] out: return self.process_row(row)
[127.0.0.1] out: File “/usr/local/lib/python2.7/dist-packages/peewee.py”, line 1959, in process_row
[127.0.0.1] out: setattr(instance, column, func(row[i]))
[127.0.0.1] out: File “/opt/redash/redash.0.10.1.b1834/redash/models.py”, line 339, in python_value
[127.0.0.1] out: return ConfigurationContainer.from_json(value)
[127.0.0.1] out: File “/opt/redash/redash.0.10.1.b1834/redash/utils/configuration.py”, line 77, in from_json
[127.0.0.1] out: return cls(json.loads(config_in_json))
[127.0.0.1] out: File “/usr/lib/python2.7/json/init.py”, line 338, in loads
[127.0.0.1] out: return _default_decoder.decode(s)
[127.0.0.1] out: File “/usr/lib/python2.7/json/decoder.py”, line 366, in decode
[127.0.0.1] out: obj, end = self.raw_decode(s, idx=_w(s, 0).end())
[127.0.0.1] out: File “/usr/lib/python2.7/json/decoder.py”, line 384, in raw_decode
[127.0.0.1] out: raise ValueError(“No JSON object could be decoded”)
[127.0.0.1] out: ValueError: No JSON object could be decoded
[127.0.0.1] out:

Fatal error: run() received nonzero return code 1 while executing!

Requested: sudo sudo -u redash PYTHONPATH=. bin/run python migrations/0003_update_data_source_config.py
Executed: /bin/bash -l -c “cd /opt/redash/redash.0.10.1.b1834 >/dev/null && sudo sudo -u redash PYTHONPATH=. bin/run python migrations/0003_update_data_source_config.py”

So, I run the file impala_ds.py directly. Please let me know how to connect impala.
Thank you so much for your reply.


#4

connected external mysql database using below command

sudo -u redash bin/run ./manage.py ds new ‘redash:mysql’ ‘mysql’ ‘Server=192.168.3.14;User=root;Pwd=root;Database=copilot_dev’

How to connect impala like external mysql?


#5

Hi Arik
Getting following error when I am trying to connect impala
Error running query: could not connect to server: Connection timed out Is the server running on host “192.168.3.164” and accepting TCP/IP connections on port 5432?

Please suggest to solve the issue.