I used the setup script to install redash inside docker on Linux 22.04
I have mysql server installed on the linux machine.

i am getting the error “(2059, ‘Plugin caching_sha2_password could not be loaded: /usr/lib/x86_64-linux-gnu/mariadb19/plugin/caching_sha2_password.so: cannot open shared object file: No such file or directory’)”

Do i have to install mysql inside docker or can it be installed anywhere ?
i tried a lot of ways to get into the docker container and install mysql inside docker , but i dont know the root password , for the docker. (the setup script didnt ask for a root password)

found a solution !!

sudo apt-get install libmysqlclient-dev (ran this on the linux machine )
sudo docker ps (get container id for redash docker)
docker exec -u 0 -it <container_name> /bin/bash (to get into docker)
sudo apt-get update
sudo apt-cache search mysql-server
sudo apt-get install (installed the default-mysql-server form the list the previous command gave)

Dont know how or why this worked , but its working now