How to disable the gravatar icon?

Issue Summary

A summary of the issue and the browser/OS environment in which it occurs.

Technical details:

  • Redash Version: 8.0.0+b32245
  • Browser/OS: Chrome/Linux
  • How did you install Redash: Docker with install script

I installed redash on a computer with no internet connection (downloaded the images with the internet and used a private registry). The redash works amazing, blazing fast and beautiful. Just the gravatar icons cloud the otherwise amazing UI. Is there a way to disable them?
My current best idea is to override the hosts file and point it to a custom dumb-server which will return a static image. Is there a better option?

I did this by updating the src attribute for every <img> tag with the profile__image_thumb or profile__image--settings class to a base64 encoded red dot. Like this:

src="data:image/png;base64, iVBORw0KGgoAAAANSUhEUgAAAAUA
            AAAFCAYAAACNbyblAAAAHElEQVQI12P4//8/w38GIAXDIBKE0DHxgljNBAAO
                9TXL0Y4OHwAAAABJRU5ErkJggg=="

It was a total of four changes and it looks like this in practice: