How to enable python as a data source?

Issue Summary

I’m not able to add python as a data source as the option is missing. Please find the attached image

Technical details:

  • Redash Version: redash:8.0.0.b32245
  • Browser/OS: Chrome
  • How did you install Redash: Using AWS AMI redash-8.0.0-b32245-1-ap-south-1 (ami-0ff23052091536db2)

You can modify the file of */redash/redash/settings/init.py , about 256 lines, append ‘redash.query_runner.python’ to the list of default_query_runners .

Of course, this is not the best solution, it should also be possible to modify the configuration file, but I am new to redash users, I do not know how to modify the V8 version of the configuration file. I hope this method can help you

@manthan-damania @zhongshaoming1

You can add Query Runners via environment variable REDASH_ADDITIONAL_QUERY_RUNNERS.

https://redash.io/help/open-source/admin-guide/env-vars-settings

Thanks, but this link seems to be for non-docker installation。@ ariarijp

Went ahead with
export REDASH_ADDITIONAL_QUERY_RUNNERS=redash.query_runner.python

Thanks for the help :grinning:

Note for Docker users: you can update this in your docker-compose.yml file. Under services.server.environment:

REDASH_ADDITIONAL_QUERY_RUNNERS: redash.query_runner.python

3 Likes