Increasing timeout when getting schema

Is there a way to increase the timeout when it tries to fetch schema details? I tried changing SCHEMAS_REFRESH_SCHEDULE value in .env file but it doesn’t work. In logs all I get is

[2020-04-23 07:54:59 +0000] [51449] [CRITICAL] WORKER TIMEOUT (pid:51468)
[2020-04-23 07:54:59,723][PID:51468][INFO][metrics] method=GET path=/api/data_sources/4/schema endpoint=datasourceschemaresource status=500 content_type=? content_length=-1 duration=30760.32 query_count=6 query_duration=8.96

I don’t think there’s a setting for this. But something looks wrong here. Why would it take almost nine hours to refresh the schema for your database? I don’t think the timeout is the problem :wink:

Right, i will have a look, but just for info it times out around 30 seconds

I’m confused, I think.

The request log you posted says otherwise:

Well, I thought this time is in milliseconds, it fails around 30 seconds everytime.

https://github.com/getredash/redash/blob/2dff8b9a00d23ef6f7a2d108c8560ec38f8f8960/redash/metrics/request.py#L20

Correct! I figured I was missing something :man_shrugging: