Is 7.0.0 released now?

#1

I’ve seen the Docker-Image with 7.0.0, is this usable right now?

0 Likes

#2

Yes. We didn’t announce yet, because we’re still verifying a few things. But the image should be safe to use.

0 Likes

#3

Great! We tried yesterday. But when trying to do the “manager db upgrade” command (we use Docker / Kubernetes) nothing happened and brought us a HTTP 500 Internal Server Error.

0 Likes

#4

Hello,
I have an ansible deployment for redash installation. Unfortunately, version 7 does not appear the results of queries.

0 Likes

#5

@XRyu A new Redash 7 build looks like it was created yesterday.

I’ve just updated from v6 to it successfully, and so far everything seems to still be working fine. :slight_smile:

1 Like

#6

@justinclift Thanks for the update :slight_smile:

We tried update to the new version as well. But the manage.py db upgrade command seemed not to work in our Kubernetes deployment. As our deployment didn’t include many data until today, we decided to clean install it, not wasting any more tries and time in this upgrade process. Hoping next upgrade will run smoother for us.

For better future we would recommend to make any upgrades triggerable from the UI when needed (like most people know from Wordpress) or even make them automatically when container starts and identifies new version. So no manual upgrades would be needed in a Docker/K8 environment.

1 Like

#7

Interesting idea. That sounds like it’d be useful. :slight_smile:

0 Likes

#8

That’s definitely something we would love to have, but need a very robust upgrade process in place before we can do this.

0 Likes