Login with google return 400 error

Issue Summary

When I login with google failed with 400 error.
400. That’s an error.

Error: invalid_request

device_id and device_name are required for private IP: http://10.12.5.54:5000/oauth/google_callback



Is it the setting error of the google credentials? Is the ip addr must be Public IP?
Thanks a lot!

Technical details:

  • Redash Version: V8.0.0
  • Browser/OS: Chrome/Ubuntu
  • How did you install Redash: Docker

You can’t use 127.0.0.1 in your Google settings. This would point back to the server in Google’s data center. If you are running Redash on your local machine then you won’t be able to login with Google without some dubious middleware like ngrok or similar.

2 Likes

Just to add to susodapop’s answer:

The address 127.0.0.1 is translated by computers as localhost https://en.wikipedia.org/wiki/Localhost
Hence if you put this in as the redirect address in the OAuth settings in your Google project, you’re telling the Google server to redirect users back to itself, when what you want to it to do it redirect users to the server actually running Redash. Therefore you need to have Redash running on an address (ideally with a DNS name like https://redash.acme.com) that your browser is going to be able to resolve to correctly connect to Redash after authenticating with Google.

See https://redash.io/help/open-source/setup and also https://redash.io/help/open-source/admin-guide/google-developer-account-setup

1 Like