Map Choropleth - Bounds issue? Formatting incorrect?

Hello everyone,

I’m running into an issue where I can’t find any kind of documentation or similar issue so I came here to get a solution.

I created a query and ended with a Map Choropleth visualization that is looking good. In my dashboard, I want this map to focus on South-East Asia by default so I picked a North East point on Google Maps and a South West point as indicated in the Bounds fields but nothing is happening.

I saved/executed the query again but it seems to not understand my map bounds? I’m guessing this has to do with formatting but I can’t think of a way to do it differently? This is how I have it at the moment:

I tried replacing the periods with commas to no avail. I also tried putting North-West and South-East points but it’s also not working.

Any idea what could be the reason of my issue right now :slight_smile: ?

Thank you for your time,

Edit: I’m on v.8.0.0 (dev) btw if that helps!

Is there anyway you can share some sample data so I can try to reproduce this? I don’t have geo data handy for debugging.

Offhand I wonder if truncating the lat and long values might help?

Sure! I appreciate you being willing to take a second look at it!

.CSVs are not supported here so here’s a link where you could download it: https://sweetspotpr.com/wp-content/uploads/test_map_bounds_csv_for_redash.csv

Here is the data as well if you don’t want to DL a file:

Country Amount
Indonesia 29
Malaysia 63
Phillipines 12
Singapore 83
Thailand 52
Vietnam 12

I did try to just keep the numbers shorter, so like 21 / 146 and -15 / 90 but it did not work either. I also tried to choose bounds points that would be in Europe so like more in the middle of the default map but it did not work either.

It’s really confusing aha…

Hmmm it works for me:

I can even drag around the viewport and it automatically adjusts the bounds corners…