Multiple errors when trying to self host according to guides

Issue Summary

It’s been really hard to self host redash and for such a big app, it’s given me more troubles than any other.

Firstly I tried the docker install method, and had issues with the wrong version of python - had to manually change the python version in the Dockerfile.

Then running npm run build gives me an error error TS2688: Cannot find type definition file for 'jest'..

So I finallly resorted to the setup.sh script. Got a fresh Ubuntu 18.04 server, and ran setup.sh only to get the error ERROR: yaml.scanner.ScannerError: mapping values are not allowed here in "./docker-compose.yml", line 3, column 23.

Am I doing something wrong? Is no one self hosting redash? Because of the amount of errors I’m seeing, I’m finding it hard to see who is relying on this technology.

Technical details:

  • Redash Version: Latest
  • Browser/OS:Ubuntu
  • How did you install Redash: Docker guide

Sorry to hear you’re having trouble with this. Most Redash users run OSS without issue so I think the problem is your machine. All that’s necessary to run Redash is to clone the OSS repo, cd into the directory and run docker-compose up -d. I just ran this with a fresh clone of the repo on MacOS Catalina and it failed at first because the tip of master has some requirements.txt conflicts which are documented here. After correcting for those it worked in three steps as documented: build the containers with docker-compose, set up the database, build the webpack assets.

Thanks for your reply.

Although I can get the server working fine and access :5000, I can’t start the webpack server at :8080.

npm install works fine but npm run build gives me the error error TS2688: Cannot find type definition file for 'jest'

It’s a fresh Ubuntu machine so I doubt it’s that, the type of errors I’m getting are really code specific it seems

Hi @huzaifahj

I can get rid of this error by installing

npm i --save-dev @types/jest

there are many other errors comes up, telling me to install many @types/* though

do you have any idea @k4s1m ?

Ubuntu 20.04
Node: 14.15.4
npm: 6.14.10


Update 1

got another error after installing all the @types/*

Error: Cannot find module 'babel-plugin-module-resolver' from '/opt/redash/viz-lib'


Update 2

simply install npm i --save-dev babel-plugin-module-resolver to make it work,

I didn’t know if there are any other problem as my server is Out of Memory at the moment :sweat_smile:

1 Like