Mysql datasource in Redash - SSL issue?


#1

Hi friends,

We just discovered redash and wanted to tried it.
After installing, we tried to add our mysql datasource, but it wouldn’t work.It returns “failed saving”

Not sure why - where can I see logs?
Could it be because I am not using SSL for redash or the mysql data source?

This is a simple research spike and having to setup SLL could be a real blocker.

We need your advice please. Thanks, in anticipation.


#2

SSL is optional and not supposed to make the save fail. You can find the log at /opt/redash/logs/api_error.log.


#3

Thanks @arikfr for the quick reply. We are relieved to hear that we can use without SSL
We use the Bitnami Paas (googlec cloud - debain) - and cant find api_error.log at that location ypu mentioned
We find logs at /opt/bitnami/apps/redash/logs

But only find redash_celery_scheduled.log, redash_celery_worker.log and redash_gunicorn.log
(and corresponding pid files)
Is this something that sounds familiar, or is it so strange that I have to follow up with bitnami? Or do you have any further tips for us?
Still wondering what caused the mysql data source to fail saving.

We really appreciate your help with this. Thanks, in anticipation.


#4

The path I mentioned is for the images we provide. If you use Bitnami, then the correct file isredash_gunicorn.log.