Not able to trigger Slack Alerts

I have added a new alert destination and entered the slack url and channel. The alert status is shown as ‘triggered’ but the message does not show in slack.

Tried the slack url using postman and that worked fine. But redash alert does not seem to post any message to slack.

Any idea how to go about troubleshooting this? Where will the log file be generated?

Can you share any details of how you configured the slack destination?

Slack:

  1. Created a new slack app by visiting https://api.slack.com/apps
  2. Enabled ‘Activate Incoming Webhooks’
  3. Add new webhook to workspace
  4. Get webhook url

Redash Alert Destinations:

  1. Visit ‘Alert Destinations’
  2. Click ‘New Alert Destination’
  3. Select ‘Slack’ in ‘Type Selection’
  4. Add name, webhook url and channel (#channelname) in configuration
  5. Click save

Redash Alerts:

  1. Click ‘Create->New Alert’
  2. Select a query that does not have any parameters
  3. Select ‘Trigger when’
  4. Select ‘When triggered, send notification’
  5. Click ‘Create Alert’
  6. Make sure alert state/status changes to ‘triggered’
  7. Select the alert and on the right hand side section ‘Destinations’, add the slack destination created earlier
  8. Wait for the alert to be triggered again (verifiy by looking at ‘last triggered’)

When I create a new alert destination, the icon is coloured. But when adding the created alert destination to an alert, the icons are grey and not coloured.

Is there a reason why the alert destination icons are greyed out?

Checked webhook alert destination as well with https://webhook.site/.

Alert destinations are not being hit.

[Edited: *hit]

Can you share a screenshot?

This raises a red flag. Are you not able to receive any notifications? Not even through email? Are you certain your criteria are triggered? It seems like the issue might not be Slack specifically.

Checked with chatwork as well. You are correct. Not able to receive any notifications on any alert destinations. Also, we checked the celery log file as well as docker logs and didn’t find any specific logs that would help. Docker logs only put out [ OK ] statements.

@susodapop I am also facing the same issue. It was working earlier. The last Alert I can find was triggered on 2nd Jan 2020 and after that, it suddenly stopped.