Parameter not working on external Site, but in Redash

I created a Dashboard with a global Dashboard Date Range parameter for several Queries.
When i use the dashboard directly in Redash everything works just fine, but as soon as i switch to my external platform, where i implemented the Dashboard, the Parameter Input fails to work for 1 table.
This one specific table always uses the Default Date range and ignores my parameter Input.

Then i tried to use a local parameter for only this one table and the problem gets even more confusing… As before, while in Redash, the new local parameter works just fine. But as soon as i switch to my other platform, the global parameter overwrites the local one. That means i can change the date range for the problematic table with the local parameters, but as soon as the global parameters are changed, the local ones are overwritten…

Is this a known issue? Does anyone have a solution for that?

Interesting bug report.

What version of Redash are you using?
Is this issue present if you access the public dashboard link directly (not embedded in your app?)
Does it affect all browsers?

Thanks for replying!

Version: 8.0.0+b32245 (a16f551e)
Yes it is also present while accessing the public link.
I tried it with Firefox and Chrome and another user of my company tried it on his computer and its always the same issue

Are you certain the type of parameter is set to a date range rather than a text parameter type?

Yes and like i said, it works perfectly fine in readash and the local parameter settings even work on the external site as long as i don’t touch the global settings…

I think i just fixed it. In the problematic table i had this line of code:

BETWEEN '{{ Date From.start }}' and '{{ Date From.end }}'

So instead of ‘Range’ there was ‘From’ and that seemed to be causing the problem. The weird part is that while in redash it still worked :person_shrugging:

That not unexpected.

Text parameters are not allowed in publicly shared dashboards. So they won’t work. It’s to prevent SQL injection.

Date parameters are allowed in public dashboards :ok_hand:

Once you changed the parameter to the correct type it’s fixed.