Problems with New Query exported from Big Query


#1

Hi all,
I just started to use redash together with BigQuery, and I am having problems with my first new query :roll_eyes: , I have created a new data source using my Google Cloud Project ID, JSON Key and it seems to be ok until I tried to do my first SQL search, then I get the error message “Error running query: Source URI must be a Google Cloud Storage location:”.

Do you have any idea of what am I doing wrong here, it seems quite straightforward but it doesn’t work. Also and just in case, I am BigQuery admin and so I created the JSON key.

Thank you for any help,
P.


#2

Sorry for the bad first impression. What did you put as a value for “UDF Source URIs”?


#3

Well, I still didn’t have the first impression but I am looking forward to play with my data :grinning:.
I left “UDF Source URI’s” empty, because I understood that this should be related to a bucket but my data is in BigQuery. Should I put some entry there?
Thank you!


#4

No, it needs to be left empty (unless you have UDFs you want to load).
But the error you describe seems to originate with trying to load a value from this field.

What version are you using?


#5

I setup an instance with Redash 2.0


#6

Can you paste the result of /api/data_sources/{data source id} here? Just omit your key file.


#8

it worked now, I just restarted the VM machine :grinning: !
Anycase, thanks for your answers!