Queries not running as scheduled


#1

Hello,

My queries are not being updated as scheduled, but when I run it manually everything works.

Here’s the system status screenshot. Queries queue (in progress and waiting) and outdated queries is also empty.

Also, I’m getting the below message on api_error.log but don’t know if is related to the above issue or not.

Traceback (most recent call last):
  File "/usr/lib/python2.7/logging/__init__.py", line 851, in emit
    msg = self.format(record)
  File "/usr/lib/python2.7/logging/__init__.py", line 724, in format
    return fmt.format(record)
  File "/usr/lib/python2.7/logging/__init__.py", line 464, in format
    record.message = record.getMessage()
  File "/usr/lib/python2.7/logging/__init__.py", line 328, in getMessage
    msg = msg % self.args
TypeError: %d format: a number is required, not NoneType
Logged from file request.py, line 32

#2

Is there anyone that can help me figure out what’s going on?

I’ve already tried to restart the redash_server, redash_celery and queries queue. No error while running those.


#3

What version are your running and did you ever solve this?