Query filter populates with -1

Hi Folks,
I am using query filters not to be confused with query parameters. Well I am using both, paramaters as the top level and then the query filters only after the parameter has been defined. While for some selections of a query parameter, the query filters are not populated and expect the user to fill these in. For other selections of the query parameter the query filter shows a -1 selected for each. (This also screws up the order formatting of the query filters) Then the user needs to delete this and then add from the drop down selection. I’d like to remove this behaviour, does anyone know why this would happen?

Example
the very top is the query parameter, selection of this allows me to choose based on the query filters.

Query filter adding a -1 and screwing up my formatting

This is what I expect, and for some selections, as seen below it works flawlessly.

Any input would be appreciated.

Any one able to help here… I have no explanations I can come up with here

Sorry for my late reply here. I’m not sure I understand what your desired behavior is. But it seems like the problem here is that query filters don’t show all by default. Does that sound right?

Appreciate the reply.

I will try and be more detailed here:

I have a query parameter, this is working. When I select from the query populated list, it is then doing a reload to load and populate the query filters.

in some cases, the query filter loads as a -1 as a default selection. When you click on the drop down of those filters you can see its loaded the data fine, but for some reason has loaded that -1 value.

As a user, I need to click on each and then clear the -1 selection, then select the data I want.

Its just a bad user experience that I can’t seem to explain why this happens on some query parameter selections, where other selections load all of the data perfectly without a -1.

ok, so I feel pretty stupid. turns out to be a problem with a query in the dashboard. One of them had a where clause which in some cases did not match the criteria of the query filters.

1 Like