Query stuck in queue and can't save it

Hi
From time to time I can’t run changed queries, they get stuck in the queue and i can’t save them.
When I run the query without changing the code - it runs smoothly. If I make even the smallest change - I can’t save and when I run it gets stuck (screenshot attached).
It is not a permissions problem. I tried restarting the browser, logging out and in of redash. nothing helps.
Please help.

Hello Guy!

If the message “Query in queue…” is displayed, it means that another query is running in the background. You can see which one in the system status page (/admin/queries/tasks). Once this query is finished, your query should run.

If that’s doesn’t solve the issue, you can try to restart the adhoc worker. It will stop every query to run, the page will display a connection error and you should be able to save your query. To restart the adhoc worker, if you’re using the docker based install, you can run ssh root@ip docker container restart redash_adhoc_worker_1

To solve the issue on the long term, I would recommend to improve your queries to be more efficient and/or increase celery concurrency (by increasing WORKERS_COUNT of the adhoc worker in the docker-compose.yml)

Hope this help!

2 Likes