Query update stuck on "Query in queue…" for ages

Hi!
I have a dashboard which I monitor every day. Yesterday the queries just stopped updated and are now stuck at “Query in queue…”

  • I have not changed anything, they worked just fine and now cannot refresh
  • When I refresh query results from the first databased, I get Query in queue which can stay in queue for 50 minutes.
  • The query I’m running usually takes no more than 20 seconds to run. Also, there’s no issue with the DB itself - I tried executing the same query using a standard DB connection tool - works fine, so the issue is on redash side, not DB side
  • I tried logging out and in again
  • tried different browsers
  • in the Test connection section it says Success
  • also tried connecting to the same DB using a different user, same result
  • one more point- queries that pull data from Google analytics and work fine.

What do the logs for your Redash instance say? From what you described it sounds like your worker has either crashed or run out of memory.