REDASH_HOME not being used?

Dear Folks,

(I can’t put links in my post :slight_smile: because I’m a new user. thus please substitute <example_org> from here on and <localhost_5000> with http://localhost:5000

I’m trying to deploy redash on my <example_org> server under the <example_org>/redash path. The server already has an nginx listening on port 80 so the redash docker-compose starts all the containers successfully, except the nginx one. But this is not a problem since the system seems to be working:

the following work
curl <localhost_5000>
curl <localhost_5000>/login
curl <localhost_5000>/static/server.5cdfe7b4f652b665b03f.css

are all successful locally on the server.

the following works from the outside

curl <example_org>/redash/static/server.5cdfe7b4f652b665b03f.css

i get to see the css.

however, when I try to

curl <example_org>/redash

it fails because the page redirects to the <example_org>/login instead of <example_org>/redash/login

I thought that this was the point of REDASH_HOME variable to allow the redash to generate prefixed urls. So I set it in the /opt/redash/env file, but as far as I can see, this does not work. The generated urls are still not prefixed with it.

Am I doing something wrong?
Is this question even clear? :slight_smile:
Can somebody provide an advice?


ah, forget about this folks. I’ve deployed under and this solved the problem :slight_smile:

1 Like

For future readers: Redash is not intended to mount at a subdirectory. It’s meant to run at the root location for the server. I believe there are some workarounds to make it work (and we’d be happy to merge a pull request making this an option). But for the moment it’s not supported as of V10.

1 Like